来自 系统操作 2019-09-25 16:34 的文章
当前位置: 六合联盟网 > 系统操作 > 正文

MAC下的铺排,安装与行使教程

凌晨在设置 Laravel 框架进程中,境遇了无数题目,因为 Laravel 的设置依赖于 composer,这里就先介绍一下 composer 的装置格局:

系统 macOS sierra。在安装Laravel此前早就配备好了MAMP,成功在该地运维了php项目(TP框架);
资料:Laravel 汉语文书档案(http://d.laravel-china.org/docs/5.4/installation )
地面开荒条件供给已经满意供给,未有尽兴homestead的安装;直接行使Composer来安装laravel
在命令行实行 (安装了curl)
curl -sS https://getcomposer.org/installer | php
注意:在执行 curl -sS https://getcomposer.org/installer | php 命令的时候唤醒curl: (56) SSLRead() return error -9806
选取了第二种方法php命令依然报错了。 通过查阅资料(http://blog.csdn.net/fys_0801/article/details/52489516)在实践curl命令在此之前先实施git config --global core.compression -1,在施行curl命令,成功下载了composer.phar文件
下一场实行
sudo mv composer.phar /usr/local/bin/composer 修改 composer的权限
sudo chmod a+x /usr/local/bin/composer
这么在顶峰即可动用composer命令了。接下来正是接纳composer来创制laravel框架的花色了
根据文书档案提示实行:composer create-project --prefer-dist laravel/laravel blog ,过了一段时间提示
[ComposerDownloaderTransportException]
The "http://packagist.org/p/provider-2017-01%24d5dac88b599b56a755b03e6ffa66
cbe560571ef4f4a3d3c6841121c671afe54a.json" file could not be downloaded (HT
TP/1.1 302 Found)
出错了。。。
快速去Google一下,在stackoverflow上边找到了相应的传道,赶紧再一次尝试一下
composer create-project laravel/laravel --prefer-dist
接下来开端慢慢的创导项目了...中间还现出四个install退步的;
不可能,只可以换到本国镜像config -g repo.packagist composer https://packagist.phpcomposer.com;在创立项目。。。比比较快就创制出来了

设置形式:

 代码如下

#下载
sudo curl -sS https://getcomposer.org/installer | sudo php -d detect_unicode=Off

#转移文件权限
sudo chmod a+x composer.phar 

#移步文件
sudo chmod a+x composer.phar

#更新
sudo composer self-update那样就足以使用 composer 了。
[root@localhost www.111cn.net]# composer
Zend Guard Loader requires Zend Engine API version 220090626.
The Zend Engine API version 220121212 which is installed, is newer.
Contact Zend Technologies at for a later version of Zend Guard Loader.

   ______
  / ____/___  ____ ___  ____  ____  ________  _____
 / /   / __ / __ `__ / __ / __ / ___/ _ / ___/
/ /___/ /_/ / / / / / / /_/ / /_/ (__  )  __/ /
____/____/_/ /_/ /_/ .___/____/____/___/_/
                    /_/
Composer version aa9c257f0efd1a54c93ba95282821a497bc15d75 2014-03-09 15:09:15

Usage:
  [options] command [arguments]

Options:
  --help           -h Display this help message.

本文由六合联盟网发布于系统操作,转载请注明出处:MAC下的铺排,安装与行使教程

关键词: